Resurs - MitID – Incident details

All systems operational

MitID

Resolved
Major outage
Started 1 day agoLasted about 5 hours

Affected

MitID

Major outage from 7:13 AM to 11:48 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    MitID is currently experiencing technical issues, which may affect access to our services. We apologize for any inconvenience this may cause.

    Kind regards,

    Resurs Bank IT