Started 11 months ago25th September, 2025Lasted about 3 hours25th September, 202510:1513:19UTC
Affected
Merchant Portal
Major outage from 10:15 AM to 1:19 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
We implemented a fix and are currently monitoring the result.
Investigating
UTC
Investigating
UTC
We are currently experiencing issues with Mercant Portal. We are working on resolving the incident as soon as possible. We apologize for any inconvenience this may cause.